Get Adobe Flash player
This game requires Flash Player

Additional Details

Developer Absolutist
Release Date November 2, 2011

System Requirements

Flash Version 9.0
Web Games Arcade Puzzle

Help

If you need assistance, please visit our Help Center.